Account access
Incident Report for 2talk
Resolved
This incident has been resolved.
Posted Jan 27, 2022 - 06:04 PST
Identified
We are currently undergoing some unplanned maintenance, during this time you are unable to access your account.
Please note that calls are still connecting.
Posted Jan 26, 2022 - 15:49 PST
This incident affected: 2talk Cloud PBX.