Switchboard
Incident Report for 2talk
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 14:38 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 06, 2023 - 11:51 PDT
Update
We have identified the issue and expect a resolution shortly.
Posted Sep 06, 2023 - 11:41 PDT
Identified
Last night we released a new service breaking the numbers management feature on the portal.
Posted Sep 06, 2023 - 11:36 PDT
This incident affected: 2talk Cloud PBX.