Faxing
Incident Report for 2talk
Resolved
This incident has been resolved.
Posted Jan 11, 2023 - 17:24 PST
Identified
A storage container inadvertently filled this morning stopping the delivery of faxes. Our support team is working to store faxing now and a fix is expected shortly.
Posted Jan 11, 2023 - 13:06 PST
This incident affected: 2vFax.